Start a new topic

FPV.Connect Install Experience

I was excited to get my Connect module today, so when i got home I installed it and was immediately disappointing.  Since we don't get any install instructions or any other information I was unsure of if I got a DOA module or if I installed it wrong. I did not know if i'm supposed to be on a certain version of firmware that allows connectivity of the Connect. I did see that there was a LED on the board but I wasn't getting anything when I powered it up. But after about 2 hours of messing around I finally got it. 

Here are the steps I took to be successful with the install.

1st- Install ribbon cable. Make sure the side of the board that has the U.FL connector and LED is facing you with the ribbon cable connector facing upward. Then make sure the 2 little tabs on the connector are pushed out. Slide cable downward into the connector until it stops, be very gentle. You should only see about 1/16" of the silver contacts showing. If not wiggle left and right while trying to push it in. I used some tweezers that were covered with heat shrink to make sure I didn't damage the ribbon cable. Once fully seated push both of those little tabs back in to lock in the cable. 

2nd- Install the 1.2.0 on to a SD card (I used a 32g card). But make sure to format the SD card first in the goggles. Even with just the DCIM folder on it, it would not update with the .orqa file in the root directory. FYI I tried to jump Firmware versions and go straight to 1.2.2 instead of doing 1.2.0 but that does not work and neither does 1.2.1. (Note: I was on 1.1.4 and when you are on a 1.1 version it will not power the ribbon cable to allow for the connect to power up. Hence why didn't get any LEDs to light up on my module.)

3rd- make sure your GPS on your phone is turned on! (this was my main issue why I couldn't connect to the app) 

4th- Go to your WiFi on your phone and try to connect to the goggles (note: the RED led is on when its powered up, but when WiFi is connected it will turn GREEN, but GREEN doesn't mean you are fully connected, you need to enter the password for it to be 100% good) when your phone asks for the WiFi password it is the last 11 charters of your goggle name that pops up in your WiFi. Example of your password will be something like   FPV1200xxxx all caps. At this point I was on 1.2.1 version and it immediately asked if I wanted to update and I did. This process worked seamless.

there is a video on the solution part of this website:

but it's nice to know, that you have at least to be on firmware v1.2.0 to get it working/powered at all.

and i think it's good to know, that you were able to update your goggles with the app, but how did this work? when the app is connected to my xperia or iphone i can't connect to the internet, to download anything.

I experienced the same thing. I got excited when I saw the FPV.Connect in my mail but quickly realised that I had no idea on how to properly install it. Due to my experience with electronics I figured out how to install it but it didn't work. It took some time to find the Freshdesk site of Orqa - why is there no mention anywhere on I even checked the firmware section on (the newest is 1.1.4) and the manual of the goggles without any reference to the newer firmware or the Freshdesk site. At the end, it was pure luck, as I was about to submit a ticket I saw the "start" header and then read the article.

Please update your website, thanks.

Login or Signup to post a comment