Start a new topic

Firmware Update not working

I've tried: - v1. 1.4 - v1. 2.0 - v1. 2.1 - different sdcards (also formatted in goggle) - 4 different power supplies I've got HW 1.0.1 with v1. 4.1 working at the moment.

I went from 1.2.0 to 1.2.1. Release notes mentioned not being able to downgrade below 1.2.0.  I was not having luck with the upgrade either at first. I did factory reset, format card in goggles, copied over firmware. I believe I may have not been waiting long enough for it to start. It took about 45 seconds after powering on the googles before the update started when it worked. 

I've waited about three minutes and could power down the goggles and nothing happened.
Bought a brand new sdcard, formatted it with the "SD card Formatter" and put the firmware file v1.2.0 on it and it started to upgrade immediately. Than I put the firmware v1. 2.2 on it and it updated again, but not that immediately as before. It's a cheap intenso class 10 - 32 GB card, the one I used to update and recorded my flights before is a SanDisk 32 GB - uhs-I. This is strange...
Login or Signup to post a comment