Start a new topic


1. On ca. every 6th bootup only the right OLED works. After a restart both work again.

2. On bootup the goggle choose a random chanel on the RAPIDFIRE MODULE

12 people have this problem

Same issue here but it only happened after a week with the new update

A quick note, I have both issues as above, only I have had both displays not come on at times. On reboot it will work. The SPI mode wouldn't work either, until reboot. Only after update problems started.


1.14 to 1.20 without FPV connect. Coming in mail

RapidFire installed

Factory Reset


1. First boot-up left screen black. second boot-up fixed.

2. Edited out. 

3. Rapidfire module is continuously beeping in flight with audio turned off on RX module.

a. Steady beep says its not a RSSI beep and i have a charged battery.

4. From Rapidfire menu back to cam screen; black screens. reboot fixed. See #6

5. Had at one time the Rapidfire menu overlaying the Orqa menu. See #10

6. DVR - 

a. Play first video halfway, 

b. pause, 

c. return to play list by holding control button down, 

d. Failed to open other video's till I played the whole video I first opened. Just got black screen. e.Back out of DVR menu gets me no FPV cam video at all. This is in reference to #4. :) 

f. Going into Rapidfire Menu brings back FPV cam video.

g. Repeat a thru c. DVR button locked up. ???DVR button also seeems to change video settings??

h. Orqa goggles completely locked up except for fan. No menu's and No power button.

i. Power plug pulled for hard power off. Plugged in. Boots up fine.

j. DVR playback joystick down - one beep, joystick up two beeps???

k. Back out of video play selection also gets you black screen.

7. Rapid fire Issue or Orqa or just operator error???

a. OSD only works for rapidFIRE#1. Why not the others?

8. Longer boot-up??

a. Thinking since 1.20 is for FPV connect that the main processor is freaking out of sorts since it's not seen.

9. Rapidfire integration issue:

a. Left joystick to select an item on menu.

b. Revert back to Rapidfire menu for channel selection.

c. Black screen

d. Left joystick selection.

e. Black screen 

f. Rapidfire menu also black.

g. Reboot

h. RF menu good.

i. Unable to repeat. Might be related to DVR issue black screen??

10. Screen overlay issue:

a. Hold down Rapid fire button for best signal selection.

b. Left joystick for setting menu

c. Menu overlays Rapidfire menu. :(

d. Orqa settings menu times out and disappears to leave Rapidfire menu.

11. Up and down buttons left side do pick freqs, but Rapidfire RF strength meters shows very brief.

Dear Pilots,

the update with a fix for the issue with the displays has been officially released and can be found in the Firmware section on our Knowledge Base (Solutions)!

All the best,

-Orqa Team

Flashing right now

@Raphael-treglia You have to enable GPS for it to work.

@Julian Im facing the same issue. Ive granted the app access to location data still crashing thou. 

After update, Rapidfire will no longer enter spi mode straight away.( will see if it overwrite once i adjust setting) 

Hi, i tested the 1.2.1 update and it seems fine to fix the grey screen.

But i still has an issue with fpv.connect app.

It was the same behavior with 1.2.0 and with 1.2.1, i'm coming from 1.1.4.

Pairing between goggle and my phone is not working.

I'm connected to the goggle's wifi easily mdp => fpv12......

But after the connexion step, the pairing check button never end to roll :/

I waited 10min but nothing changes, try with reboot phone, uninstall / install app again, kill app and retry but nothing change.

I'll try with another phone. Mine is a Mi mix 2s from xiaomi

Hope i'll find the bug :)

it was just to keep you informed

EDIT: after testing on another phone (iphone) it is working. Seems that the app doesn't worked for mi xiaomi mi mix 2s ://

works good after adding gps location :) you should add a check or auto activate gps in the app! will be awesome

I upgraded to 1.2.1. After pressing the rec button, all operations will be disabled.

The only way to do this is to unplug the power cable.

updated to v1.2.2 just yesterday and my rapidfire selects a random channel everytime i turn on the goggles.

tried to disable the SPI mode, butthan there's only a gray screen.

Now that my connect module is installed, the rapidfire works as expected. Don't like it anyway
It's fine for me now. My rapidfure keep same channel after reboot on 1.2.2. works without any problem now! Great job orqa !
Login or Signup to post a comment