Start a new topic

Livestream Delay

First of all, this feature is absolutely amazing and the quality of the stream is just insanely good.

One thing that is a little anyoing though is the delay of the livestream. It get's worse the longer the stream is running, which is a indication that there's some bottleneck in encoding/decoding performance for livestreams. 

Since the delay is reset once I reset the livestream in the app I think it's most likely happening on the side of the app?

Using a Samsung Galaxy S8.

I am confident that you are able to solve this problem in some way or another. 

1 person has this problem

I also have a Galaxy S8 and it is not working well at all. I get the loading wheel of death, and most times it does not connect. I have to reboot the goggles and restart app, struggles to link up. I get it and its okay for about a minute. Only been able to link to it twice the 6 times ive tried to connect so far. Somethings not right

Delay isn't a bug at all, think about the latency! Encoding in goggles, send over wifi, decode in the app, show stream. There will always be "a delay".

As I wrote previously the latency is increasing the longer the stream is active. A certain latency will always be there sure, but after streaming ~3 minutes the latency already is about 5 seconds for me. For someone watching through the phone the video and real location will be noticably off.

 A fresh started stream has a delay of around 0.5 - 1s I would say, which is totally acceptable.

There's definitly a bottleneck either in the app or the firmware, where stuff gets buffered. I am sure this can be solved without sacrificing quality. This definitly is a bug.

Have to post a small update. I did try it again today and the delay stayed consistent the whole time... For now it seems to have been a one time thing...

Out of the few times I used livestreaming, I got about 2 seconds of delay the whole time.

I have this constant increase in delay aswell. It gets so worse it start stuttering and buffering and eventually it goes to a spinning wheel. 

I then have to power cycle everything a couple of time and hope i can reconnect. Ive tried force stopping the app aswell but i still have hit and miss on restarting the live stream then.

Im using a Samsung S9+ Exynos with Android 10 and one UI 2.1. None of the power savings modes are enabled on the phone.

It was better for me with the intial version of the app i would always connect right away and the delay was a steady amount.

Hope you guyes can figure it out 

Login or Signup to post a comment