Start a new topic

Firmware damaged !!

After 40 min waiting to update from 1.1.5 to 1.2.0 on full batteries

Firmware damaged !!

Bootloader mode

Insert SD card with update file to repair firmware

Anyone saw that message?

1 person has this problem

I also had that problem I just tried again and it worked the second time.

I tried several times with all the firmwares we have with no success (

try using the sdcard_orqa.bin beside the firmware you try to install. no other files on the card!


(3.93 MB)

this was the original answer from the team to the post/question called
"My goggles turned off during the update and now they won't boot up, what should I do now?" 

Add Orqa .bin file along with the update file and update the goggles as described in the Firmware update process.

oh and i had problems with upgrading too and i did this:

- new card

- format with "sd card fomatter" (i guess there is a mac version too)

- placed the firmware bin file on it

- put it in the goggles

firmware update started immediately (without sdcard_orqa.bin file)

Ok, thanks! Will try your solution by evening )

Solution doesn't help (

This wasn't mine, just came across this a few weeks ago. So you need to open a ticket and the team will get in touch with you in a jiffy. This orqa team is nice and reliable!

I opened ticket yesterday. Orqa's solution didn't fix as well. Waiting for their another one

I opened one today. After 2.4.1. upgrade, I started to make a Profile and the screen Froze.

I turned off and on still no power to the goggles. 

Problem solved, during upgrade the Orqa's default to double tapping the power button on the goggles. 

I use adapter cord for power which is why the Orqa's weren't turning on. 

Take note that if you have to use this method to turn on your Orqa's, you have to double tap the power button( tap, release, tap hold) extremely fast. Just like DJI but, way faster. I took me a few tries. 

1 person likes this
Login or Signup to post a comment